The forums have permanently moved to This forum will be kept around in read-only mode for archival purposes. To learn how to continue using your existing account on the new forums, check out this thread.

Results 1 to 11 of 11

Thread: Dynamic text field in nested mc

  1. #1

    Dynamic text field in nested mc

    I'm having problems with a dynamic text field not displaying its text. It's nested several clips deep, but if I check the "display variables" debug option, it's receiving the text from the variable; if just doesn't show.

    After searching around a bit, I've tried the following things:

    * Setting the mask through ActionScript, rather than through the GUI
    * Making the dynamic text field its own movie clip
    * Embedding the font for the dynamic text field

    None of these, either individually or in any combination with the other methods, have shown the text in the text field. Anyone have any other ideas?


  2. #2
    Barn's Avatar
    Registered User
    Is this an authored textfield or a dynamically created one?

    And are you using a non-system font?

  3. #3
    Authored, using a non-system font. I tried it with a system font as well, but the result was the same.


  4. #4
    Barn's Avatar
    Registered User
    As silly as they sound (but it happens), yet easy enough to check, a few other things that can prevent the text from appearing are:

    • Having the textfield simply too small to display the specified text.
    • Having inadvertently set the font color to the same color as the background color (of either the textfield, or if no textfield background color, whatever is behind the textfield).
    • Having the visibility for the textfield or some parent timeline set to false.
    More obscure, but also possible:
    • Having a setRGB value applied to some parent that makes the textfield the same color as the rest of the movieclip.
    • Not having the font in question installed.

  5. #5
    hmmm, I'm beginning to think that you just can't mask dynamic text fields that use system fonts inside of an mc.
    I fooled around with it a number of times and it never seems to work.


  6. #6
    Barn's Avatar
    Registered User
    Oh, I thought you said you were using NON-system fonts.

  7. #7
    can you post an .fla?
    i would try using a different font, just as a test to see if that makes a difference.

  8. #8
    I've tried several different fonts. The main one I'm trying to use is called Onyx, but I've also tried Arial and the sans serif system font.

    Barn, I've spent enough time tracking down problems that turned out to be something stupid that your suggestions don't seem silly to me at all. The text field's definitely large enough. The font's set to twelve point, and its about 200px by 250px. The background is black at 30% opacity, over another background that's composed of dark colors. The font color is set to white. I haven't played with visibility at all, nor with setRGB.

    As for posting the .fla, I tried with the initial post, but it was too large. I'm pretty sure I can cut down the filesize dramatically (for some reason, all the gradiants got rasterized when I imported them), but that'll have to wait until Monday, when I'm back at work.

    Thanks for the suggestions so far, everyone.


  9. #9
    Quote Originally Posted by Barn
    Oh, I thought you said you were using NON-system fonts.
    Not me, I was using dynamic text fields with system fonts, specifically "_sans"
    As I said on WH, I have not found a solution to masking dynamic text within a movie clip, I'm beginning to think you just cant.

  10. #10
    Turns out you can do it, you just can't do it by setting the variable. You have to set the text on the field directly. Weird, eh? Answered here:


  11. #11

    Now make it scroll...!

    Hey everyone. I've been reading this forum thread while working on my own masked dynamic text, and have finally figured it all out. I have:

    1. dynamically loading HTML rendered text in an mc.
    2. An animated mask revealing the mc functioning.

    What I don't have is a functioning scrollbar. My scroll bar works completely fine under normal circumstances, but I think having to nestle the text in an mc screwed things up. I assume it's some sort of depth/level problem, but I can't for the life of me figure it out.


    p.s. to see what I'm talking about, go to and open the window. Then click on bio.


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Home About Meet the Moderators Advertise

 Link to Us


Copyright 1999 - 2012