The forums have permanently moved to forum.kirupa.com. This forum will be kept around in read-only mode for archival purposes. To learn how to continue using your existing account on the new forums, check out this thread.


Results 1 to 1 of 1

Thread: AS 2: font from shared library

  1. #1

    AS 2: font from shared library

    Need to load font from shared library, to use it in main application then needed.
    Problem - do not work in IE7 and IE8. all working fine in FF. Problem it'self: code from loaded swf do not run.

    Explanation:
    file: arial_n_lib.fla - on the stage (main scene) movieClip - arial_n_mc. It contains dynamic textfield with needed Font-Arial and Embeded symbols(cyrilic, latin etc...). MovieClip properties: in first frame, for action script, export for runtime sharing and swf path

    file: arial_n.fla - shared library container: on the stage (main scene) movieClip- arial_n_mc (dragged from arial_n_lib.fla ). On the next layer AS2.0 code:

    Code:
    this.TimeOut = function()
    {
        if(this.id == undefined)
        {
            this.id = setInterval(this,"TimeOut",1000);
        }
        else
        {
            clearInterval(this.id );
            trace("registering txt field::"+this.arial_n_mc.arial_n_txt)
            _global.regFont(this.arial_n_mc.arial_n_txt);
        }
    }
    this.TimeOut();
    file: ie8test.fla - main app(test). Code in fla (showing here main parts - do not show trivial things)
    Code:
    .
    .
    .
    my_mcl.addListener(myListener);
    my_mcl.loadClip(myURL, this.dummy);
    
    _global.regFont = function(tfld) //tfld - Textfield object
    {    
    
        var tf = tfld.getTextFormat();    
        trace("font="+tf.font)
    }
    so loading shared libary container. In FF I see trace: font=Arial, in IE7,8 - function regFont did not called. Why??

    Please help, it's very urgent! Big project stopped because of this

    P.S. changing _global.regFont to _root.regFont - does not help
    P.P.S. compiled for player version 9 and 10. Played in FlashPlayer v10 - no results
    Attached Files Attached Files
    Last edited by Ghostbob; August 19th, 2009 at 05:54 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Home About kirupa.com Meet the Moderators Advertise

 Link to Us

 Credits

Copyright 1999 - 2012