Results 1 to 2 of 2

Thread: Conversion of vCam to oop prob

  1. #1
    8
    posts
    Registered User

    Fla Box Conversion of vCam to oop prob

    Well, this is kinda old, but I haven't managed to fix this problem.
    Code:
    1180: Call to a possibly undefined method addFrameScript.
    first of all, it points out to the first line of the As script, which says "Package";
    Kinda odd, isn't it?
    the second problem, is that I got no addFrameScript function... so why is it calling it and getting an "undefined"?

    This all happens in a conversion I made to a vCam I've downloaded, I just tried to make it OOP

    I've attached the vCam to this post, please help me
    Attached Files Attached Files

  2. #2
    Do you have any script on the main timeline?

    This has happened before when I have code on the main timeline AND have a document class.

    Basically, when you have code on the main timeline, when Flash compiles it, it uses the "addFrameScript()" function to add scripts to the exact frames where they will be needed. This video discursses it a bit:
    http://www.gotoandlearn.com/play?id=70

    And for some reason, Flash acts up if you have code in both locations, why I do not know.

    If that isn't the problem, just ask again.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Home About kirupa.com Meet the Moderators Advertise

 Link to Us

 Credits

Copyright 1999 - 2012