Page 1 of 2 12 LastLast
Results 1 to 15 of 20

Thread: C#: Where to begin?

  1. #1

    C#: Where to begin?

    So, I downloaded Visual C# from Microsoft's website. I installed everything. I have .net framework 2, 3, and 3.5 (for some reason).

    When I start VC#, I get error # 1.
    When I try to create a new project, I get error # 2.

    For last 2 days, I've been deleting, installing, and uninstalling a few things, and these errors just made my day worse...

    I'd like to ask, what exactly do I need for C#?
    And, how do I fix these errors?

    Thanks. I searched online, but not in too much detail (because my head hurts now).
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	vcerr1.jpg 
Views:	38 
Size:	24.0 KB 
ID:	47340   Click image for larger version. 

Name:	vcerr2.jpg 
Views:	24 
Size:	17.5 KB 
ID:	47341  

  2. #2
    TheCanadian's Avatar
    10,302
    posts
    Noo doot aboot it, eh?
    I'd try re-installing, but I don't really know.
    Proud Montanadian
    We tolerate living and breathing. And niches.

    Name Brand Watches

    Maybe getTimer() or TweenMax is the answer to your problem . . .

  3. #3
    Oh, I forgot to say that. I uninstalled it, restarted the computer, and reinstalled it. Still the same thing. I even went to Kirupa's blog, downloaded some C# files, and tried to open with VC#. It said the file extension was not supported by C#, which is really stupid, because I had double-clicked the file, and it opened C# by itself.

    Thanks!

  4. #4
    It looks like your install didn't fully complete. It is looking for templates to load and it isn't finding them. Do you have .NET 3.5 or .NET 3.5 SP1 Beta installed?

    Also, try running the executable with the /resetskippkgs and see if that does anything.

    Great, now even Kirupa is { facebooking | twittering }

  5. #5
    2.0 is SP 1
    3.0 is SP 1
    3.5 doesn't say anything about SP.

    About running with /resetskippkgs: The error also says that, but I'm not sure what to do there.

    Ok, searching resetskippkgs led me to this: http://forums.msdn.microsoft.com/en-...-2e24dfe92097/

    I'm going to try that out later and see what happens. Thanks Kirupa and TheCanadian!

  6. #6
    if you want developed desktop software:
    http://www.icsharpcode.net/OpenSource/SD/

    or you wanna develop aspnet :
    dreamveawer

  7. #7
    kdd, you're a student right if so: https://downloads.channel8.msdn.com/

    Theres no real benefits to Professional as you will be new to it, but later on when you get into the more advanced sections of application development, VS express has tiny limits (that can sometimes be worked around).

    Worth a shot to try to see if Pro makes a difference, I personally have never seen the error messages you showed though.

    Join #kirupa | Click the under my Username | CL | Jeff

  8. #8
    So, I've successfully removed .net 1, 2, and 3. Now only have .net 3.5. Going to reinstall the whole vc#, let's see what happens.

    Thanks Tuncays and Temp.

    Tuncays, for some reason I'd feel better having vc#.

  9. #9
    More errors...

    Think I need to install .net framework 2.0 now... Ugh...

    I can't install 2.0, can uninstall 3.5, **** keeps saying I need to insert a CD to uninstall, wtf?

    I'm seriously starting to hate this SOB.


    Edit: I'm just going to delete everything related to "framework" and related to ".net" right now. Going to do a very clean installs then and will see what happens.

    Edit: How many .NET Frameworks do I really need? How many do you guys have? Kirupa, how many do you have?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	vcerr3.jpg 
Views:	17 
Size:	37.6 KB 
ID:	47352  
    Last edited by kdd; July 30th, 2008 at 04:05 PM.

  10. #10
    Just did clean install. Now I've .NET Framework 2.0, 3.0, and 3.5. And still VC# giving me stupid errors.
    2 = sp 1
    3 = sp 1
    3.5 = no sp.

    Someone please tell me how to make this b**** work. I'm really losing it now...

  11. #11
    I only installed .NET 3.5 SP1 Beta, but because I am running Vista, I also have .NET 2 and 3 installed as part of the OS.

    The installer takes care of setting these things up for you automatically (removing old versions of the framework, etc.), so I really don't know why it isn't working.

    Great, now even Kirupa is { facebooking | twittering }

  12. #12
    Is Visual C# free or do I have to pay for it? Maybe it's not working, because it's free and/or I downloaded it from microsoft's site... Just an idea, which I highly doubt is true.

  13. #13
    It's def free. MS is very gracious with even its most advanced softwares.

    You did redownload it right before doing that second install? (although I'm pretty sure it scans itself to make sure its package if fine before installing).

    If you didn't that is probably the case.

    Join #kirupa | Click the under my Username | CL | Jeff

  14. #14
    Could anyone suggest any other alternative software to VC#? I think my computer may be screwed up now. I've been doing lots of installs, uninstalls, and deletes these days, so that maybe a reason, though not a likely one...

    Thanks for helping guys! I appreciate it!

  15. #15
    Nothing really compares to VS C#, I would highly recommend you format as there is probably something wrong with your computer anyway and install it again (with a fresh download). (I never and will probably never understand why sharpdevelop program was made.)

    kdd, did you redownload it the 2nd time you installed though?

    Join #kirupa | Click the under my Username | CL | Jeff

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Home About kirupa.com Meet the Moderators Advertise

 Link to Us

 Credits

Copyright 1999 - 2012