The forums have permanently moved to forum.kirupa.com. This forum will be kept around in read-only mode for archival purposes. To learn how to continue using your existing account on the new forums, check out this thread.


Page 1 of 2 12 LastLast
Results 1 to 15 of 29

Thread: How to reset password in WAMP server

  1. #1

    Afrostyle How to reset password in WAMP server

    i have created mysql database in wamp server and after setting some user privileges i am not able to open phpMyAdmin page, i get access denied page (screenshot attached)

    i think its something to do with a password for the root user,

    how do you reset the password?

    anyone?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	error.jpg 
Views:	6803 
Size:	20.1 KB 
ID:	44523  
    Last edited by Novate; November 1st, 2007 at 08:18 PM.

  2. #2
    If you have the command line (in which is start -> run -> type "cmd") and if you can type "mysqladmin" - and see a bunch of output text, you're good to go. Simply type this:

    mysqladmin -u root password NEWPASSWORD

    Just replace NEWPASSWORD with the password you want to use. You can also replace "root" to change that users' password, if it exists.

  3. #3
    Quote Originally Posted by robertark View Post
    If you have the command line (in which is start -> run -> type "cmd") and if you can type "mysqladmin" - and see a bunch of output text, you're good to go. Simply type this:

    mysqladmin -u root password NEWPASSWORD

    Just replace NEWPASSWORD with the password you want to use. You can also replace "root" to change that users' password, if it exists.


    thanks so much

    i will try this out in few hours

  4. #4
    Quote Originally Posted by robertark View Post
    If you have the command line (in which is start -> run -> type "cmd") and if you can type "mysqladmin" - and see a bunch of output text, you're good to go. Simply type this:

    mysqladmin -u root password NEWPASSWORD

    Just replace NEWPASSWORD with the password you want to use. You can also replace "root" to change that users' password, if it exists.

    it does not work

    its says 'mysqladmin' is not recognized as an internal or external command, operable program or batch file

  5. #5
    358
    posts
    Under Investigation
    sqlmyadmin ?
    You are not your system specs. You are not your banners. You are not your uptime stats. You are not your downloads size. You are not your post count.

  6. #6
    well phpmyadmin also has a file called config.inc.php where there's a password variable which is left blank by default:
    Code:
    $cfg['Servers'][$i]['password']
    you can set that to whatever password you want and it may work that way, though I wouldn't recommend it.

    robertark's method is the right way. the only thing is you have to navigate to the proper folder in command prompt, which is wampfolder/mysql/bin then you can do:

    Code:
    mysqladmin
    if it shows crap you're in the right place if not keep trying, if you're in the right place you can run

    Code:
    mysqladmin -u root password NEWPASSWORD
    Let us live so that when we come to die even the undertaker will be sorry. - Mark Twain
    Don't PM me your CSS, xHTML, JS or PHP questions. I will not reply to ANY IE6 questions.

  7. #7
    Quote Originally Posted by simplistik View Post
    well phpmyadmin also has a file called config.inc.php where there's a password variable which is left blank by default:
    Code:
    $cfg['Servers'][$i]['password']
    you can set that to whatever password you want and it may work that way, though I wouldn't recommend it.

    robertark's method is the right way. the only thing is you have to navigate to the proper folder in command prompt, which is wampfolder/mysql/bin then you can do:

    Code:
    mysqladmin
    if it shows crap you're in the right place if not keep trying, if you're in the right place you can run

    Code:
    mysqladmin -u root password NEWPASSWORD
    i will sure try this out, thanks so much

  8. #8

    Not Working

    Output: 'phpmyadmin' not recognized as an internal or external cammand

  9. #9

    I got it to work!

    Quote Originally Posted by vineeth View Post
    Output: 'phpmyadmin' not recognized as an internal or external cammand
    I installed WAMP using the tutorial found HERE and accidently set my password wrong -- I found this thread on a google search trying to figure out the same thing. I found that the folder I needed to be under when in the Command Prompt was
    Code:
    C:\wamp\bin\mysql\mysql5.0.51b\bin
    To find the proper folder, go into your wamp folder using Windows Explorer, click "bin", "mysql", then find where the other "bin" folder is under that.

    To get to the proper place in the command prompt enter:
    Code:
    cd C:\wamp\bin\mysql\mysql5.0.51b\bin
    Then (as they said before...)
    Code:
    mysqladmin -u root password NEWPASSWORD

  10. #10
    Quote Originally Posted by nathanbrauer View Post
    To get to the proper place in the command prompt enter:
    Code:
    cd C:\wamp\bin\mysql\mysql5.0.51b\bin
    Then (as they said before...)
    Code:
    mysqladmin -u root password NEWPASSWORD

    I entered that path and it says the path is invalid, however, I can navigate that path fine through "my computer"

    Is there another way to get to it or something else i can do?

  11. #11
    Quote Originally Posted by nathanbrauer View Post
    I installed WAMP using the tutorial found HERE and accidently set my password wrong -- I found this thread on a google search trying to figure out the same thing. I found that the folder I needed to be under when in the Command Prompt was
    Code:
    C:\wamp\bin\mysql\mysql5.0.51b\bin
    To find the proper folder, go into your wamp folder using Windows Explorer, click "bin", "mysql", then find where the other "bin" folder is under that.

    To get to the proper place in the command prompt enter:
    Code:
    cd C:\wamp\bin\mysql\mysql5.0.51b\bin
    Then (as they said before...)
    Code:
    mysqladmin -u root password NEWPASSWORD
    I have the same problem as described in this thread. I tried what you recommend and it returns the attached message (see attachment). What to do? Please help!!
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	cmd-error.jpg 
Views:	4576 
Size:	58.9 KB 
ID:	50604  

  12. #12
    Nobody is giving the complete instructions. Come on guys, this work is all in the details.

    You have to stop the mysql service first. You can do so by clicking on your wamp icon or by going into the administrator/services panel--then run the above...

    Wait a sec, come to think of it, I believe there is even a link if you click on the wamp icon running in the taskbar. I believe there is a link to mysqladmin right there. I don't have it running now so I am not sure but I believe this to be right..

    Good luck

    Thanks,

    webdevoman

  13. #13
    Quote Originally Posted by webdevoman View Post
    Nobody is giving the complete instructions. Come on guys, this work is all in the details.

    You have to stop the mysql service first. You can do so by clicking on your wamp icon or by going into the administrator/services panel--then run the above...

    Wait a sec, come to think of it, I believe there is even a link if you click on the wamp icon running in the taskbar. I believe there is a link to mysqladmin right there. I don't have it running now so I am not sure but I believe this to be right..

    Good luck

    Thanks,

    webdevoman
    3 year old thread champ
    Let us live so that when we come to die even the undertaker will be sorry. - Mark Twain
    Don't PM me your CSS, xHTML, JS or PHP questions. I will not reply to ANY IE6 questions.

  14. #14

    MySQL password setup

    1.Install wamp2 server

    2.Start->run->cmd->

    3.Type cd\ and press enter

    4.Locate your mysql directory(like this is my default directory C:\wamp
    \bin\mysql\mysql5.1.36\bin)


    5.After like this you should have do C:\wamp\bin\mysql\mysql5.1.36
    \bin>
    mysql -u root -h 127.0.0.1 -P 3306 -p press enter after you got
    Enter Password don't put anything simply click enter button

    6.After like this mysql>

    7.simply type mysql>use mysql;
    mysql>show tables;
    mysql>select * from user \G;

    8.You can set your new password: mysql> UPDATE mysql.user SET
    Password=PASSWORD('xxxx') WHERE User='root';
    (where replace 'xxxx'
    with your new password)
    (eg.mysql> UPDATE mysql.user SET Password=PASSWORD('muthu') WHERE
    User='root';
    )

    9.Finally type mysql> FLUSH PRIVILEGES;
    mysql>exit;

    10.Check your settings: mysql> mysql -u root -p
    enter password:*****

    press enter button.....




    Thank you guys

  15. #15
    i tryed that and on step 4 i get something that says "the filename, diretory name , or volume label syntax is incorrect . "

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Home About kirupa.com Meet the Moderators Advertise

 Link to Us

 Credits

Copyright 1999 - 2012