Results 1 to 4 of 4

Thread: PEAR installed but not working.

  1. #1

    PEAR installed but not working.

    i checked the server and pear is definitely installed...at command line, typing

    pear list

    brings up all the installed packages.

    Now, I also checked the include_path of the php.ini file and its set to .:/usr/share/pear
    But when I put into my code:

    Code:
    require('Mail.php');
    the script wont even run and doesn't produce anything.
    it works correctly on another server, so i know there is nothing wrong with the code for sending email with PEAR, but its that damn include path that is not picking up the Mail.php file which is in the usr/share/pear/ folder that is defined in the include_path.

    Any suggestions please?
    Thanks.
    "First time it's a mistake, do it again and it's stupidity."

  2. #2

  3. #3
    i ran phpinfo but the referencing is correct....could open_basedir have anything to do with it since it seems restricted to only the httpdocs folder?
    "First time it's a mistake, do it again and it's stupidity."

  4. #4
    i don't know much about open_basedir. can you just copy the Mail.php file into a manually created include folder and then require it from there?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Home About kirupa.com Meet the Moderators Advertise

 Link to Us

 Credits

Copyright 1999 - 2012